Skrevet av Emne: Atom editor on Ubuntu linux fails, Running without the SUID sandbox [SOLVED]  (Lest 3841 ganger)

Utlogget Floyd-ATC

  • Livstidsdiktator
  • Administrator
  • Guru
  • *****
  • Innlegg: 541
  • Karma: +12/-0
    • MSN Messenger -
    • Vis profil
    • E-post
Spent several weeks banging my head against the wall with this problem. When trying to start "atom" it just never appeared. When trying with "atom -f" (to run in the foreground) I would get the following error messages:
Kode: [Velg]
[] Running without the SUID sandbox! See https:
[] Multiple instances of AudioManager detected
[] Multiple instances of AudioManager detected
[] X IO error received (X server probably went away)

I focused on the first error message for a long time and found all sorts of red herrings, closed bug reports and no actual solutions. Finally it dawned on me that the actual problem was the LAST error message. I access my desktop via X2GO and therefore have a pretty special DISPLAY environment variable. Maybe that had something to do with it?

Kode: [Velg]
# cp /usr/lib/x86_64-linux-gnu/ /opt/atom
# sed -i 's/BIG-REQUESTS/_IG-REQUESTS/' /opt/atom/

...and suddenly atom worked.


Det finnes 10 typer mennesker;
de som forstår binærtall, de som ikke gjør det, og de som forstår Grey code.